I think there’s a redbook entitled something to the effect of AIX for Unix Admins, but I’m not sure.
http://www.redbooks.ibm.com
All of the manuals, man pages, etc are online, and usually installable as a web process on local AIX boxen as well.
http://techsupport.services.ibm.com/server/support?view=pSeries
Basically, the core is:
It’s unix plus more
It has a thing called ODM, which is a small database, sorta like registry, that stores all config info.
cfgmgr will scan the hardware and configure new devices
cfgmgr -v will show verbose output and errors
lsdev -C | more shows your devices. `defined` and `available` are your options. `defined` usually means there was an error.
mkdev -l
rmdev -l makes a device defined from available
rmdev -dl competely deletes the device.
If it is `defined`, the /dev node will be gone, so make sure that you don’t have a 3 gig tar file in /dev
errpt and errpt -a show the error report. Generally, this is very useful. Only High Availability (HACMP) and SP/Cluster 1600 (RSCT/PSSP) use syslog.
`smitty` is your friend. It’s a menu based admin tool. Explore it greatly. You can press [F6] in most places prior or after submitting, and it will tell you the actual command it ran.
`smit` runs `smitty` or a gui smit, based on your terminal type and whether you have a DISPLAY exported.
`websm` is a java/web system manager which is also supposed to be good, but I don’t use it much (yet)
it’s /etc/filesystems, not /etc/fstab
most of the daemons start with system resource controller.
Because of this, inittab doesn’t have the rc#.d entries.
It’s called `srcmaster` and should stay running.
`lssrc -a` lists them and their status.
`stopsrc -s
vmstat and iostat (standard tools) are good
WLM (Workload Manager) allows you to sandbox groups of processes so they don’t completely rape a running system. You can crush a system with WLM, but if it’s setup right, I’d highly recommend making root’s getty and shells have 5% CPU and some amount of ram, so in a really borked system, you’d still be able to do stuff.
AIX uses a logical volume manager rather than partitions or slices. Terminology is:
Physical Volume: Device definitaion for a hard drive. Typically hdisk#.
Volume Group: A group of physical volumes Typically `blahvg`. Originally limited to 32 PVs, but AIX 4.3.3 brought in `BIGVG` support, which I think is 512 PV’s per VG.
Logical Volume: Belongs to a VG. Made of Logical Partitions. This functions like a partition in PC land. There’s a limit of like 500 LV’s in a VG.
Logical Partition: Allocation unit for LVs consisting of 1, 2 or 3 Physical Partitions, depending on the number of mirrors required.
Physical Partition: Typically, the largest disk size divided by 1016 and rounded up to the next power of 2 megs. AIX v4.3.2 brought in a PP size factor variable which allows you to reduce the number of PVs in exchange for more PPs per PV. (eg a factor size of 2 allows 2032 PPs on up to 16 PVs).
Filesystem is called JFS (or JFS2 in AIX 5). JFS is basically UFS with a transaction log (hence the J for Journalled File System). The transaction log is called the loglv.
JFS supports sizes up to I think 2tb, with files up to 256g. I think JFS2 is higher than this.
CDE is standard (or `COSE` pronounced cozy in older AIX versions).
KSH is the standard shell, and many of AIX’s programs and utils are written in ksh, which is good, because you can do `set -x` in the script for verbose debugging output.
I think that’s mostly it. The AIX 5L differences redbook and the AIX System Adminstration Certification Studyguide redbook both should give decent and condensed training on it. Also, IBM has good training, so if your company has an education card, you could ask to use that for AIX courses at Luna road for reduced or zero additional cost (depending on the type of ed card).
If you have specific questions, just ask, though if you guys have a support contract, 800-CALL-AIX can hook you up with tech support.